Dell Unity: Impossibile rinnovare/rimuovere il certificato VASA a causa di una catena di certificati troppo lunga (correggibile dall'utente)

Riepilogo: Ci sono molti motivi per cui non è possibile rinnovare/rimuovere un certificato VASA. In questo articolo viene descritta solo la procedura di rinnovo/rimozione quando la convalida del certificato non riesce a causa di "Catena certificati troppo lunga". ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Quando si tenta di rinnovare il certificato VASA da vSphere, si verifica l'errore:     
 
"Il certificato del provider non è valido. È vuoto, non valido o scaduto, non è ancora valido, revocato o non supera la verifica del nome host."

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Il problema non riesce a risolvere utilizzando l'articolo della KB:     
Quando si tenta di rimuovere un certificato da Unity utilizzando UEMCLI, eseguire una delle seguenti attività:    
  • L'output ha esito positivo, ma il certificato rimane nel sistema.
  • L'output ha esito negativo con errore: "Il certificato non esiste. (Codice d'errore:0x6000940)"
Esempio di entrambi i punti:
service@spb~# uemcli -no -u admin -p /sys/cert -id vasa_http-vc1-servercert-1 delete Operation completed successfully. service@spb~# uemcli -no -u admin -p /sys/cert show 1: ID = vasa_http-vc1-cacert-1 Type = CA Service = VASA_HTTP Certificate ID = vasa_http-vc1-cacert-1 service@spb~# uemcli -no -u admin -p /sys/cert -id vasa_http-vc1-servercert-1 delete Operation failed. Error code: 0x6000940 The certificate does not exist. (Codice d'errore:0x6000940) service@spb~# uemcli -no -u admin -p /sys/cert show 1: ID = vasa_http-vc1-cacert-1 Type = CA Service = VASA_HTTP ID certificato = vasa_http-vc1-cacert-1

Causa

Per questo problema specifico, è stato riscontrato che la catena di certificati era troppo lunga. La profondità massima stabilita per la verifica SSL in Unity OE 5.0.6 e versioni precedenti è 1 e questo particolare certificato ha una profondità di 3.

Risoluzione

Questo problema verrà risolto in una prossima versione di Unity OE.

Per ulteriori informazioni sulle versioni di Unity OE, fare riferimento all'articolo 20641 della Knowledge Base: Matrice delle revisioni di Dell EMC Unity OE (correggibile dall'utente)

È disponibile una soluzione alternativa che comprende:     
  1. Il supporto tecnico modifica il valore SSL Verify Depth.
  2. Supporto tecnico per l'eliminazione di tutti i certificati elencati nell'array
  3. Il supporto tecnico riavvia i servizi di gestione (ciò non interromperà la produzione)
  4. L'amministratore di Unity aggiunge Unity come provider di storage VASA su vSphere.
Per implementare questa soluzione alternativa sull'array Unity, contattare il supporto e citare il numero articolo 185269.

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Proprietà dell'articolo
Numero articolo: 000185269
Tipo di articolo: Solution
Ultima modifica: 20 ott 2025
Versione:  5
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